[CDBI] installation problem Class-DBI-v3.0.9

Thomas Kwan (eTechfocus) thomask at etechfocus.com
Sun Oct 9 16:11:50 BST 2005


I got an error when installing 'Class-DBI-v3.0.9'. Anyone knows why?

[root at hippo Class-DBI-v3.0.9]# perl Makefile.PL
Warning: prerequisite version 0 not found.
Could not eval '
            package ExtUtils::MakeMaker::_version;
            no strict;

            local $VERSION;
            $VERSION=undef; do {
                use version; $VERSION = qv('3.0.9');
            }; $VERSION
        ' in lib/Class/DBI.pm: Can't locate version.pm in @INC (@INC contains: /usr/lib/perl5/site_perl/5.8.6/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.4/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.3/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.6 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.6/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.4/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.3/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.6 /usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl/5.8.4 /usr/lib/perl5/vendor_perl/5.8.3 /usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.6/i386-linux-thread-multi /usr/lib/perl5/5.8.6 .) at (eval 28) line 7, <FH> line 10.
BEGIN failed--compilation aborted at (eval 28) line 7, <FH> line 10.
WARNING: Setting VERSION via file 'lib/Class/DBI.pm' failed
 at /usr/lib/perl5/5.8.6/ExtUtils/MakeMaker.pm line 486
Writing Makefile for Class::DBI
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.digitalcraftsmen.net/mailman/private/classdbi/attachments/20051009/82edb0a3/attachment.html


More information about the ClassDBI mailing list