[CDBI] Odd Class::DBI error since upgrading Perl and doing a

Matt S Trout dbix-class at trout.me.uk
Fri Feb 10 18:40:09 GMT 2006


On Fri, Feb 10, 2006 at 10:13:14AM -0800, jmessrie at cox.net wrote:
> Yes, I am running v3.0.14.  I just double-checked.  In addition, I do not use might_have (which is the problem mentioned in the bug listed below).  So this is occuring in other part of the CDBI code.  Also, I just found out that another one of my scripts is now constantly failing with that error.  Here are the only types of deletes the script performs:
> 
> 1) Object->search(key => $value)->delete_all;
> 2) my $obj = Object->retrieve($id);
>      $obj->delete if defined $obj;
> 
> And these are all done within one transaction.

If your code's relatively simple you could try bringing it up on
DBIx::Class::CDBICompat as a quick fix; we seem to be fast approaching the
point where a CPAN upgrade of DBIx::Class is substantially less likely to
break anything than one of Class::DBI (based on the completely unscientific
sample called "reports I'm getting from the field", so YMMV  - we long since
switched our production stuff to Class::DBI::Frozen::301 to avoid just this
sort of silliness).

-- 
     Matt S Trout       Offering custom development, consultancy and support
  Technical Director    contracts for Catalyst, DBIx::Class and BAST. Contact
Shadowcat Systems Ltd.  mst (at) shadowcatsystems.co.uk for more information

 + Help us build a better perl ORM: http://dbix-class.shadowcatsystems.co.uk/ +




More information about the ClassDBI mailing list