[CDBI] Bug in object index not resolved

Edmund von der Burg edmund.vonderburg at gmail.com
Wed Feb 22 15:37:30 GMT 2006


Have now reported over RT:

  http://rt.cpan.org/Public/Bug/Display.html?id=17805

Cheers,
  Edmund.


On 21/02/06, William Ross <will at spanner.org> wrote:
> On 21 Feb 2006, at 14:35, Edmund von der Burg wrote:
>
> > Hello,
> >
> > a while back I posted a test script (attached) that showed up a bug in
> > the object index that means that a new row whose PK comes from a
> > sequence is not added to the index correctly, although this may only
> > affect users of postgres. In the thread that followed a solution came
> > to light that fixes this problem in 3.0.12:
> >
> >        # Line 578 or so of Class/DBI.pm 3.0.14
> >
> >        # now that we have a complete primary key, add this to the
> >        # object index
> >        if ( $Weaken_Is_Available ) {
> >          $self = $class->_init( $self );
> >        }
> >
> >
> > Could this fix be added to the next release. Currently it very
> > difficult to work with CDBI and new objects, especially in tests where
> > you create one, change it and then find that it does not work.
>
>
> The only way to change cdbi is to talk to Tony Bowden directly. He
> doesn't take part in (or see) this discussion. The best way to do
> that is to make a bug report at rt.cpan.org:
>
>         http://rt.cpan.org/Public/Bug/Report.html?Queue=class-Dbi
>
> I've found that he's very responsive to bug reports, especially if
> they come with patches.
>
> best,
>
> will
>
>


--
In reality I'm evdb at ecclestoad.co.uk - http://ecclestoad.co.uk




More information about the ClassDBI mailing list