[CDBI] Re: Installing on perl 5.8.0

Edward J. Sabol sabol at alderaan.gsfc.nasa.gov
Tue Feb 28 23:57:21 GMT 2006


Judd Taylor asked:
> I can't seem to install Class::DBI on a machine running perl 5.8.0,
> because the prereq 'version' won't install. What version of Class::DBI
> started using the 'version' module?

Version 3.0.2 is the first version which uses the somewhat annoying version
module.

> There's no way version will install with perl 5.8.0. I think the lowest
> it will go is 5.8.1...

Three options:

1. Change the Class::DBI source code from 

use version; $VERSION = qv('3.0.14');

to

use vars qw($VERSION);
$VERSION = '3.0.14';

and see if it passes all tests. It should, I hope. If it does, you should be
safe to install and use.

2. Upgrade to a recent version of Perl.

3. Install Class::DBI 3.0.2.

Personally, I would go with option #1.

Hope this helps,
Ed




More information about the ClassDBI mailing list