[CDBI] add_column - bug or feature?

Peter Speltz peterspeltz at gmail.com
Mon Jan 9 18:42:55 GMT 2006


On 1/9/06, Kate Yoak <kate at longmedia.com> wrote:
>

> $class->__grouper->add_group(TEMP => $accessor);
> I swiped this from Relationship::IsA whose code hasn't change as far as I
> can tell - and it probably fails too.
>

I thought this was  strange too. Not sure whether this is a bug of
feature. I think is is preparation for the future versions where
column objects will be powerful tools (if I understand the direction
CDBI is heading correctly)  I have just  taken over IsA and have a
patched version  I have been using on CDBI 3.12.  I am about to take
all the debugging statements out or  make them optional is probably
more like it because I'm sure i will need them sometime.  Attached is
the patched version and let me know if it does not work for 3.13 .
Also email me if you want an IsA version without the debugging
statements. It may be a week before I have it on an SVN server .


> Cheers,
> Kate
> _______________________________________________
> ClassDBI mailing list
> ClassDBI at lists.digitalcraftsmen.net
> http://lists.digitalcraftsmen.net/mailman/listinfo/classdbi
>
>
>


--
pjs
-------------- next part --------------
A non-text attachment was scrubbed...
Name: IsA.pm
Type: application/x-perl
Size: 14046 bytes
Desc: not available
Url : http://lists.digitalcraftsmen.net/mailman/private/classdbi/attachments/20060109/e0b8de37/IsA.bin


More information about the ClassDBI mailing list