[CDBI] installation problems ...

Francis Dierick francis.dierick at psb.ugent.be
Mon Feb 12 15:18:53 GMT 2007


Hi,

Install went fine via CPAN, but i'm having a bit of trouble using  
Class::DBI. When I try to use it, I get this:

[frdie at psbdev01 ~]$ perl -e 'use Class::DBI'
Storable object version 2.15 does not match $Storable::VERSION 2.13  
at /usr/local/perl-5.8.7/lib/5.8.7/x86_64-linux/DynaLoader.pm line 253.
Compilation failed in require at /usr/local/perl-5.8.7/lib/site_perl/ 
5.8.7/Class/DBI/ColumnGrouper.pm line 31.
BEGIN failed--compilation aborted at /usr/local/perl-5.8.7/lib/ 
site_perl/5.8.7/Class/DBI/ColumnGrouper.pm line 31.
Compilation failed in require at /usr/local/perl-5.8.7/lib/site_perl/ 
5.8.7/Class/DBI.pm line 17.
BEGIN failed--compilation aborted at /usr/local/perl-5.8.7/lib/ 
site_perl/5.8.7/Class/DBI.pm line 17.
Compilation failed in require at -e line 1.
BEGIN failed--compilation aborted at -e line 1.

Then, guessing something is wrong with Storable, I do:

[frdie at psbdev01 ~]$ perl -e 'use Storable'
Storable object version 2.15 does not match $Storable::VERSION 2.13  
at /usr/local/perl-5.8.7/lib/5.8.7/x86_64-linux/DynaLoader.pm line 253.
Compilation failed in require at -e line 1.
BEGIN failed--compilation aborted at -e line 1.

We've tried updating both Storable and Class::DBI, but not a real  
solution. Suggestions?

Downgrading Storable to 2.13? Re-installing DynaLoader?

Cheers - Francis




More information about the ClassDBI mailing list