[CDBI] Problem with Class::DBI installation on OS/X

Victor Danilchenko danilche at cs.umass.edu
Fri Jan 5 18:13:29 GMT 2007


     Hi,
     I am making a new Class::DBI installation (for existing codebase) 
on OS/X, and none of my CDBI classes work. I keep getting error messages 
like these:

Ask::Queue::Message can't load Ask::Queue::Ticket: Ask::Queue::Ticket 
can't load Ask::Subject: Can't locate object method "_require_class" via 
package "Ask::User" at 
/Library/Perl/5.8.6/Class/DBI/Relationship/HasMany.pm line 71.


Ask::AccountType can't load Ask::User: Can't locate object method 
"meta_info" via package "Ask::History" at 
/Library/Perl/5.8.6/Class/DBI/Relationship/HasMany.pm line 34.
Compilation failed in require at /Library/Perl/5.8.6/Class/DBI.pm line 
1223. at /Library/Perl/5.8.6/Class/DBI/Relationship/HasMany.pm line 26


     I saw someone in the archives mention that this may be a problem 
with incomplete upgrades, but mine is a fresh install from CPAN. This 
code works fine on another system, Linux, both under RHEL and Ubuntu. 
Does anyone have any idea what's wrong?

     Thanks in advance.

-- 
|  Victor  Danilchenko  | When in danger or in doubt,        |
| danilche at cs.umass.edu | run in circles, scream, and shout. |
|   CSCF   |   5-4231   |                    Robert Heinlein |



More information about the ClassDBI mailing list